• Como Instalar PowerShell en Linux

    por  • 10 febrero, 2017 • El Blog de Rigo • 0 Comentarios

    Ya anunciamos que PowerShell, la “poderosa” herramienta de Microsoft para extender un poco más las capacidades de la terminal que viene por defecto con Windows NT ha sido liberada y ya es de código abierto y además han creado una versión para Linux. Sinceramente yo me quedo con Bash o cualquier otro shell antes que PowerShell, porque me parecen mejores y más prácticos a la hora de usarlos.

    No obstante, puede que algunos desarrolladores o profesionales que necesiten trabajar con PowerShell agradezcan que también esté disponible para Linux, y por supuesto para todos aquellos que opinen lo contrario que yo, y crean que PS es una mejor alternativa a las existentes en el mundo Unix… Por eso, en este artículo vamos a explicar cómo se puede instalar una de las últimas versiones de esta herramienta de Microsoft en nuestra distro.

    Bien, los esfuerzos de Satya Nadella y la renovada Microsoft para dejar atrás la era de esa Microsoft tan cerrada han dado algunos furtos, y éste es uno de ellos. Si quieres probarlo tú mismo, puedes hacerlo (según tu distribución) por ejemplo así para Ubuntu:

    curl https://packages.microsoft.com/keys/microsoft.asc | sudo apt-key add –
    curl https://packages.microsoft.com/config/ubuntu/16.04/prod.list | sudo tee /etc/apt/sources.list.d/microsoft.list
    sudo apt-get update
    sudo apt-get install -y powershell

    Mientras que para CentOS sería algo como:

    curl https://packages.microsoft.com/config/rhel/7/prod.repo > /etc/yum.repos.d/microsoft.repo
    yum install -y powershell

    Ya sabes que según tu distro o versión, los procedimientos pueden cambiar. Finalmente, para ponerlo en funcionamiento, tan solo teclea:

    powershell
    Si todo ha ido bien aparecerá el prompt de PowerShell, que será algo así como PS/>

    Fuente

    Artículo original: Como Instalar PowerShell en Linux

    Deja un comentario

    Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *