• Detectada vulnerabilidad grave en Ubuntu

    por  • 19 diciembre, 2016 • Linux Adictos • 0 Comentarios

    Click here to view the embedded video.

    Hoy se han detectado una serie de vulnerabilidades bastante graves en el sistema operativo Ubuntu, un agujero de seguridad que permite ejecutar códigos con privilegios de administrador en el sistema operativo, algo que puede hacer que un usuario no deseado pueda ejecutar código malicioso en tu equipo.

    La vulnerabilidad fue detectada por Donncha O’Cearbhaill, un experto de seguridad Irlandés que incluso ha hecho un vídeo sobre la vulnerabilidad, el cual puedes ver en la parte de arriba de este vídeo.

    Esto concretamente se hace con una vulnerabilidad del programa Apport, un programa que reporta errores en Ubuntu. Este programa genera un archivo con la extensión .crash, el cual se puede usar para ejecutar código de Python con privilegios de root aprovechando otra vulnerabilidad del programa PolicyKit, con todo lo que eso conlleva.

    Esto se produce porque el programa Apport no limpiaba los archivos .crash y los dejaba ahí, algo que permitía a cualquier atacante ejecutar el código con los privilegios de administrador.

    Esto supone un gran problema para la gente con sistemas operativos Ubuntu, ya que esta vulnerabilidad está presente desde Ubuntu 12.10 en adelante. Además se ha reportado el fallo en algunos sistemas operativos basados en Ubuntu, como por ejemplo el famoso Linux Mint.

    Imagínate el problema que supone esto para un sistema operativo servidor de Ubuntu, el cual puede alojar información confidencial de grandes empresas. Imagínate que llega alguien y entra a estos servidores con privilegios de root, copia los archivos confidenciales de los proyectos de la empresa y luego los vende al mejor postor, sin duda sería un escándalo.

    Eso si, desde Canonical como siempre han estado muy rápidos y ya han parcheado la vulnerabilidad. Por este motivo, si tienes un sistema operativo Ubuntu o basado en el mismo, urge actualizar con los comandos habituales(apt-get update y apt-get upgrade) para poder volver a estar seguros.

    El artículo Detectada vulnerabilidad grave en Ubuntu ha sido originalmente publicado en Linux Adictos.

    Artículo original: Detectada vulnerabilidad grave en Ubuntu

    Deja un comentario

    Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *